[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Getting a strange symbol when trying to use backslash.
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Getting a strange symbol when trying to use backslash.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Pages: 1 2  

Posted by Daret   (6 posts)  [Biography] bio
Date Tue 19 Oct 2010 05:34 AM (UTC)
Message
I get a symbol that looks like a capitol W with a horizontal line through it when i try to type in (or paste in!) a backslash. This is seriously impeding my ability to use the client's advanced scripting functions.

Any help would be greatly appreciated
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Tue 19 Oct 2010 05:36 AM (UTC)
Message
Sounds like you have the wrong keyboard type set in Windows. Or, perhaps, a strange font set up. What font are you using?

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #2 on Tue 19 Oct 2010 05:44 AM (UTC)
Message
It would also help to know what version of MUSHclient you are using, and what operating system (eg. Windows XP / Ubuntu).

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Daret   (6 posts)  [Biography] bio
Date Reply #3 on Tue 19 Oct 2010 05:56 AM (UTC)
Message
I'm using the correct keyboard settings. I checked.

Windows Xp. Mushclient Version 4.61
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #4 on Tue 19 Oct 2010 06:11 AM (UTC)
Message
What font are you using?

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Daret   (6 posts)  [Biography] bio
Date Reply #5 on Tue 19 Oct 2010 06:16 AM (UTC)
Message
Default.

I have not really changed hardly any of the settings from the way they were/are upon install. The only thing I did was check the auto-repeat box. Other then that. all I've done is load some plugins. load my triggers. aliases. and variables. And then realized that when i loaded all my triggers all the '\' got changed into the weird 'W' with the horizontal line through it. and the triggers won't work anymore
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #6 on Tue 19 Oct 2010 06:23 AM (UTC)
Message
I've never heard of anything remotely like this. Can you take a screenshot?

When you say you loaded "my triggers. aliases. and variables" - this isn't the first time you used the client then? So it used to work and stopped working?

When you say "the triggers won't work anymore" it sounds like they used to work, and now don't work. It's not like you just downloaded the client and can't get anything to work, right?

Is there anything you did recently that might have changed things? Like, upgrading the client from a previous version? Applying a Window Service Pack? Getting a new plugin?

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Daret   (6 posts)  [Biography] bio
Date Reply #7 on Tue 19 Oct 2010 06:31 AM (UTC)
Message
hmm. i problably should have mentioned that this is a different computer. And one that was used before i had it. and so the previous user may have changed some settings that could have caused this, maybe some kind of foreign language thing.
[Go to top] top

Posted by Daret   (6 posts)  [Biography] bio
Date Reply #8 on Tue 19 Oct 2010 06:31 AM (UTC)
Message
can't seem to take a screenshot either. this computer is still weird to me.
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #9 on Tue 19 Oct 2010 06:33 AM (UTC)
Message
How did you check that the backslash is otherwise working? MUSHclient doesn't do anything fishy with the input mechanism and just takes it straight from Windows, if memory serves.

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #10 on Tue 19 Oct 2010 06:39 AM (UTC)
Message
A fresh install of Windows might be called for. Not for MUSHclient per se, but if you can't get screenshots to work, well it sounds fishy.

Try typing backslashes into other programs, like Notepad, or Crimson Editor.

http://www.crimsoneditor.com/

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Daret   (6 posts)  [Biography] bio
Date Reply #11 on Tue 19 Oct 2010 06:40 AM (UTC)
Message
i opened notepad and typed it there. i also opened a web browser and typed it there. I'll even type it for you right now! \\\\\\\\\\\\\\\\\\\\\\

Seems to be working fine outside of the client. I can't imagine what the problem can be. I doubt it's anything wrong with the client. but it's certainly strange

I have used the client before with great success and I thank you very much for making it, and keeping up with developing it.

[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #12 on Tue 19 Oct 2010 06:50 AM (UTC)
Message
Windows can have different per-application keyboard settings, if I remember correctly. Can you check that MUSHclient itself is using the right settings? I think you can enable the language bar or something and see if the input language changes as you move the focus to MUSHclient.

Do *all* MUSHclient windows exhibit this behavior? E.g., the input box, dialog boxes, the MUSHclient notepad, standard Windows dialogs like 'save' from MUSHclient, etc.

Also, this comment might be worth looking into:
Quote:
And then realized that when i loaded all my triggers all the '\' got changed into the weird 'W' with the horizontal line through it.

When you say that you 'loaded' the triggers, does that mean copy/pasting them into the triggers dialog box, copying a world file, pasting xml somewhere, or what?

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #13 on Tue 19 Oct 2010 07:02 AM (UTC)

Amended on Tue 19 Oct 2010 07:03 AM (UTC) by Nick Gammon

Message
Daret said:

it's certainly strange



Strange is not the word. :-)

Well I would get screenshots working one way or another, and show us what it is. The exact character may give a clue. I looked up my Unicode book and couldn't see anything quite like you described.

You said triggers stopped working. Was that triggers with backslashes in them? Or all triggers?

It vaguely reminds me of the problems I had trying to play Oblivion under Windows Vista. There was a "cheat" key (tilde, or ~) which brought up a command window where you could type things. This worked perfectly under XP, but simply did nothing on Vista. The funny thing was, you could type ~ into notepad or Word, or any other program.

I spent hours trying to fix that (without success). There were suggestions that some infra-red remote driver was responsible.

All I can suggest is, if this is a second-hand PC, that some software someone installed is catching the backslash key.

You are probably best off reinstalling Windows anyway. If this isn't a PC you started with, who knows what malware or viruses are on it?

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #14 on Tue 19 Oct 2010 07:52 AM (UTC)

Amended on Tue 19 Oct 2010 07:54 AM (UTC) by Worstje

Message
It's not a bug, it is nothing strange even. It is a simple Windows setting that causes this as a side effect.

Windows supports a thing called a default code page which is used for applications that do not support Unicode. MUSHclient, despite some improvements, falls under that umbrella. Were you to look at Control Panel -> Regional and Language Options -> Advanced, you'd find that setting. (Currently on XP, so in W7 the stuff might be called slightly different.)

You probably have it set to use a Japanese codepage by default. Some programs have recommended changing it to that in the past in order to support displaying katakana and those fantastic other characters, but those programs tended to be ancient and in need of updating anyway. You probably want to set it back to English (United States).

For some more information on this, see:
http://blogs.msdn.com/b/michkap/archive/2005/09/17/469941.aspx
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


16,086 views.

This is page 1, subject is 2 pages long: 1 2  [Next page]

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]