[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Every version above 4.42 crash just after start
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Every version above 4.42 crash just after start

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Hemdall   (6 posts)  [Biography] bio
Date Tue 28 Sep 2010 06:08 PM (UTC)
Message
Hello,

My friend is experiencing strange error resulting in client shutdown everytime he turns on version of mushclient higher than 4.42
According to what he says just after receiving first line from mud and he is receiving this report:
Typ zdarzenia: B
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #1 on Tue 28 Sep 2010 06:10 PM (UTC)

Amended on Tue 28 Sep 2010 06:14 PM (UTC) by Worstje

Message
Sounds weird. Did he try a fresh install?

And just to confirm, 4.42 works, but 4.43 crashes? Exactly like that?

Also, other information like the OS (XP, Vista, 7) and the bitty-ness (32-bit, 64-bit) would be of much use.

Yet another edit... Googling brought me to this page: http://www.mail-archive.com/notepad-plus-plus@lists.sourceforge.net/msg01177.html

As I am not sure what the polish text means it might be some innocent text, but if the entire computer is crashing that seems to point out something else is wrong with your computer that does not necessarily involve MUSHclient.
[Go to top] top

Posted by Hemdall   (6 posts)  [Biography] bio
Date Reply #2 on Tue 28 Sep 2010 06:13 PM (UTC)
Message
Typ zdarzenia: B
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #3 on Tue 28 Sep 2010 06:17 PM (UTC)
Message
Typ zdarzenia: B is all I see in your posts, and that is not really something I can work with. Maybe a copy/paste error?
[Go to top] top

Posted by Hemdall   (6 posts)  [Biography] bio
Date Reply #4 on Tue 28 Sep 2010 06:18 PM (UTC)
Message
My apologies, for some reason forum cuts my messages at some point.
He is working on Windows XP Pro SP2
Every version up to 4.42 works properly, every version above 4.42 crash after establishing connection and receiving the line asking for name.
The mud he plays on is using MCCP - could be that the reason?
Typ zdarzenia: Blad
Zrodlo zdarzenia: Application Error
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 1000
Data: 2010-08-09
Godzina: 13:13:50
Uzytkownik: Brak
Komputer: Klinika
Opis:
Aplikacja powoduj
[Go to top] top

Posted by Hemdall   (6 posts)  [Biography] bio
Date Reply #5 on Tue 28 Sep 2010 06:21 PM (UTC)
Message
It looks that polish fonts are the problem and text is cutted of as soon as first polish font is reached - I hope it will work this time.
Typ zdarzenia: Blad
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #6 on Tue 28 Sep 2010 06:21 PM (UTC)
Message
Can you paste the entire thing to a site like pastebin.com, and put the link down here? Those have no limit for as far posts go.
[Go to top] top

Posted by Hemdall   (6 posts)  [Biography] bio
Date Reply #7 on Tue 28 Sep 2010 06:28 PM (UTC)
Message
http://pastebin.com/HeDuDzrX
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #8 on Tue 28 Sep 2010 06:32 PM (UTC)
Message
Hrm, I cannot do much with that I am afraid. Once more, just to be concise... 4.42 works, 4.43 and more recent versions like 4.62 all crash?

I can't see what changed between 4.42 and 4.43 since Nick only put MUSHclient on github starting at 4.45, so all I have is the changelog to go by, and I can't figure it out based on that.
[Go to top] top

Posted by Hemdall   (6 posts)  [Biography] bio
Date Reply #9 on Tue 28 Sep 2010 06:37 PM (UTC)
Message
AS far as I know I'm afraid so - every version above 4.42 crashes.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #10 on Tue 28 Sep 2010 09:31 PM (UTC)

Amended on Thu 30 Sep 2010 09:20 PM (UTC) by Nick Gammon

Message
Hemdall said:

The mud he plays on is using MCCP - could be that the reason?


That is very likely. You can disable MCCP in the Output configuration. I would try that first.

I note that version 4.43 mentions MCCP in the release notes "10. Fixed bug where MUSHclient would crash if an attempt was made to turn MCCP on more than once (ie. turning it on whilst already decompressing).".

http://www.gammon.com.au/scripts/showrelnote.php?version=4.43&productid=0

This says it is fixing a bug, not introducing one, but it is interesting that MCCP was being tinkered with at that point.

Can you be more specific about "every version above 4.42 crashes"? Surely he didn't try all 20 of them? Try the latest one - 4.63 (or 4.61 as 4.63 is a bit experimental).

Version 4.53 for example updated the zLib library (the decompression library). Maybe badly formed compression data might cause it.

Also is he using Unicode? Some strange UTF-8 sequence might be responsible.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


5,398 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]