[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Wine
. . -> [Subject]  Socks4/Socks5 Ubuntu
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Socks4/Socks5 Ubuntu

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Toruk   (15 posts)  [Biography] bio
Date Sat 26 Apr 2008 05:41 PM (UTC)
Message
I just installed Ubununtu and I cant get mushclient to connect using a proxy.. Is this able to be done?? Is it something to do with the Ubu having a port closed??
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio
Date Reply #1 on Sat 26 Apr 2008 06:11 PM (UTC)
Message
Are you sure the proxy works?

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Toruk   (15 posts)  [Biography] bio
Date Reply #2 on Sat 26 Apr 2008 07:04 PM (UTC)
Message
Yes im positive the proxy works

this is the error I get whenever i try to connect

unable to resolve host name for "themudsipaddress.org", code = 1103(this is a non-recoverable error)

and yes the mud is up and working too..

[Go to top] top

Posted by Toruk   (15 posts)  [Biography] bio
Date Reply #3 on Sat 26 Apr 2008 07:05 PM (UTC)
Message
hrm instresting I got it working and I found out why. I guess under windows if you start a proxy with 0 it just ignores it but under linux and using wine it will throw up an error and wont connect.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #4 on Sat 26 Apr 2008 09:13 PM (UTC)
Message
Starts with 0? Where do you mean? The IP address?

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Toruk   (15 posts)  [Biography] bio
Date Reply #5 on Sat 26 Apr 2008 09:20 PM (UTC)
Message
Yeah for some reason the sock i was using was like 058.76.123 not the exact one... but it worked fine like that under windows but It didnt want to work under wine like that.
[Go to top] top

Posted by Pompey1   (12 posts)  [Biography] bio
Date Reply #6 on Wed 26 Nov 2008 06:41 PM (UTC)
Message
Just guessing

It's a string being converted to a number ...

A leading zero in a string passed to a linux library might be interpreted as meaning treat the number as octal, not decimal, so "058" would be an invalid string to convert.

Windows, on the other hand, may be coded not to consider the leading 0 as meaning octal?

This might explain the problem, and if so, might be something that's worth being aware of.

Pompey1
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


11,671 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]