[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Python
. . -> [Subject]  Getting Python to work with Mushclient
Home  |  Users  |  Search  |  FAQ
Register forum user name
Forgotten password?

Getting Python to work with Mushclient

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Posted by Delu   (4 posts)  [Biography] bio
Date Mon 13 Dec 2010 02:17 AM (UTC)

Amended on Mon 13 Dec 2010 02:19 AM (UTC) by Delu

My friend is having problems getting Python to work with Mushclient. She has ActivePython 2.66 installed.

These are the errors she's getting when she tries to install a plugin written in Python (this plugin works perfectly fine for me):


[WARNING] C:\Working folder\joy documents\MUSH\MUSHclient\worlds\plugins\Loki_System.xml
Line 124: Could not initialise script engine (Cannot load)


Error number: -2147221164
Event: loading scripting engine
Description: Error -2147221164 occurred when loading scripting engine: Class not registered
[Go to top] top

Posted by Nick Gammon   Australia  (21,652 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Mon 13 Dec 2010 03:50 AM (UTC)
Search this forum for "2147221164". There are a few posts about it. Make sure your friend downloaded the 32-bit installer (x86) and not the 64-bit one.

The latest version seems to be ActivePython from this site:


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Delu   (4 posts)  [Biography] bio
Date Reply #2 on Mon 13 Dec 2010 04:06 AM (UTC)
Yes, she downloaded the 32-bit installer.

I've looked through the threads in this forum for that error, but most of them seem to have to do with the python.org install of Python, and recommend ActivePython as the solution. As she started out with ActivePython in the first place, I'm not quite sure what she's supposed to do.

She's also tried running PythonPath}\Lib\site-packages\win32comext\axscript\client\pyscript.py.
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #3 on Mon 13 Dec 2010 04:16 AM (UTC)
Upto now, I haven't been able to figure out what makes it work for some people and not for others, as I never was able to troubleshoot these installation issues with someone who had them. I've had a couple of friends who have had these issues, but somehow they either never solved it or it never came up again. Personally, I haven't had that problem.

My best guess is that you ought to make sure to run as an administrator when you install Python. The COM related stuff requires administrator privileges, and maybe something is bugged in there that it doesn't ask you to give it those privileges, and that it silently fails.

Again: I'm just guessing. But running the appropriate stuff as an admin might help (be it the installer, the ax_client.py script, or both.)
[Go to top] top

Posted by Rakon   USA  (123 posts)  [Biography] bio
Date Reply #4 on Sun 19 Dec 2010 02:17 AM (UTC)
In addition to the ActivePython, you need to ensure you have the pywin32 bindings downloaded and installed


After that, run the ax_client script and restart MUSH.

Yes, I am a criminal.
My crime is that of curiosity.
My crime is that of judging people by what they say and think, not what they look like.
My crime is that of outsmarting you, something that you will never forgive me for.
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum

[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]