[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  SMAUG
. -> [Folder]  Running the server
. . -> [Subject]  Telnet Server Problems
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Telnet Server Problems

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Renakh   (4 posts)  [Biography] bio
Date Sun 01 Aug 2004 05:49 AM (UTC)
Message
Hello,

I'm having a problem with a people trying to connect to my mud on the server. People can connect to my webpage and to the shell by ssh. For some reason no one can connect to the server by telnet. I have my router forwarding port 23 and port 5555 (the muds port) to make sure that everything would work out and yet no one seems to be able to connect.
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio
Date Reply #1 on Sun 01 Aug 2004 06:25 PM (UTC)
Message
Can you connect to your own server? Make sure all the ports used are being allowed by any router, firewall, or virus scanner.

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Renakh   (4 posts)  [Biography] bio
Date Reply #2 on Sun 01 Aug 2004 06:33 PM (UTC)
Message
I have the main ports forwarded, 21,22,23,80. I also have the 5555 port forwarded because I thought maybe i needed my mud port forward as well, but I still get no remote connection. I can only telnet to it by localhost. (Or localhost, by ssh) You can connect to the webpage, and you can connect to ssh. http://69.133.96.32 or http://novotellus.game-host.org. The only thing that wont allow remote connections is Telnet.
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio
Date Reply #3 on Sun 01 Aug 2004 07:40 PM (UTC)
Message
Just telnet? You mean other clients will work?

You said you can connect to it via localhost, so I assume the game is running.

This does sound like a problem with blocked ports, or something you haven't allowed yet with the router.

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Renakh   (4 posts)  [Biography] bio
Date Reply #4 on Sun 01 Aug 2004 08:11 PM (UTC)
Message
Yes, You can connect by SSH and http. So, if its the ports then what ports would you say I should forward to try and fix it. As I have said, I got the ssh,telnet,ftp,http, and my mud port already forwarded to my computer.
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio
Date Reply #5 on Sun 01 Aug 2004 10:21 PM (UTC)
Message
You're running Smaug correct? Smaug does use more than one port. Not sure what they are though, my MUD is changed to use only one port.

SSH and HTML use different ports. Usually HTML uses 80, while SHH uses 22. If both those work, but the MUD doesn't, I'm pretty sure its a port issue. Search through old topics, I'm pretty sure you could find something about the ports used, or how to fix this.

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #6 on Sun 01 Aug 2004 11:32 PM (UTC)
Message
Quote:

I have the main ports forwarded, 21,22,23,80. I also have the 5555 port forwarded because I thought maybe i needed my mud port forward as well,


There is no "maybe" about it. If the MUD is accepting connections on port 5555 that is the port that needs to be forwarded. The other ports you mention are for ftp, ssh, telnet and http.

Personally I wouldn't forward the other ports (21, 22, 23) because all that is doing is giving ftp, ssh and telnet access to the rest of the world. That is, if they guess your password they can delete or corrupt everything.

I would check that the router is not blocking port 5555, and is also forwarding it, to the correct PC.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Renakh   (4 posts)  [Biography] bio
Date Reply #7 on Mon 02 Aug 2004 12:09 AM (UTC)
Message
Well, I have my other ports so that other people can connect. Once I get all the bugs worked out of the server I'll be hosting a few muds for some friends. I have them setup now so that if I have a problem *like now* if someone needed to connect to the server they would be able to login to it and mess with it to try to see what is wrong.
[Go to top] top

Posted by Nick Cash   USA  (626 posts)  [Biography] bio
Date Reply #8 on Mon 02 Aug 2004 03:50 AM (UTC)
Message
Probably a stupid question, but have you checked what port SMAUG is actually running on? It is not set to 5555 by default, you need to go in and change it yourself, recomplie and w/e else.

~Nick Cash
http://www.nick-cash.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


5,271 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]