[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  Forum software
. -> [Folder]  Administration
. . -> [Subject]  Weird forward/back problem
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Weird forward/back problem

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Fri 12 Feb 2010 10:35 PM (UTC)

Amended on Fri 12 Feb 2010 10:37 PM (UTC) by Worstje

Message
Since the last week, maybe two weeks, I've been noticing some odd behaviour on the Back and Forward buttons when using Opera 10.10. I need to press them twice to be 'effective'.

If I look carefully, I notice that after initially loading the page (which completes as evidenced by the loading indicator disappearing), it ninja-loads the same page again, or so I assume. The loading indicator will appear again for a tiny little moment.

This is further evidenced if I look at my back-button history right now: it shows the Administration page listed twice (prior to that, I only opened the main page here.)

I can't really test this on other browsers (IE is the crappiest piece of software ever on W7 x64, and I have nothing else installed), but the Gammon forums are the only place in which this behaviour has ever happened, thus I think it is a recent change here that causes it. As I said, it is quite recent.

I'd appreciate it if this could be fixed, since it is bloody annoying. I thought for a while my opera was bugged when the back button got all temperamental on me. :D

Edit: Oh, and when actually going back a page, it immediately reloads again, thus wiping my Forward history as well. As I said, quite bloody annoying this. :)
[Go to top] top

Posted by Twisol   USA  (2,257 posts)  [Biography] bio
Date Reply #1 on Fri 12 Feb 2010 11:06 PM (UTC)
Message
I don't have this issue on Chrome, Firefox 3.5.7, or IE8. Perhaps it's the Google Translate script that I think Nick recently added? Try disabling Javascript and see if it still occurs.

'Soludra' on Achaea

Blog: http://jonathan.com/
GitHub: http://github.com/Twisol
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #2 on Sat 13 Feb 2010 12:20 AM (UTC)
Message
I installed Opera and can reproduce the problem, however only on Opera it seems.

I suspect Twisol is right - when you select a language under Google Translate the page indeed reloads (translated), but under Opera it looks like it does it anyway.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #3 on Sat 13 Feb 2010 12:33 AM (UTC)

Amended on Sat 13 Feb 2010 12:36 AM (UTC) by Worstje

Message
Bah, annoying. I'm not turning my JS off permanently, though. This is the first Javascript related problem I've had in ages with Opera, and I refuse to add kludges and crap. Hopefully Google will fix it soon. :/

Edit: I fixed it by blocking the URL of the external Javascript. Everything works wonders again now, thanks for pointing out the source of the problem. :)
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #4 on Sat 13 Feb 2010 12:37 AM (UTC)
Message
Do you use the translations? Do you translate into Dutch for example? Maybe an option for forum users to suppress the translation option.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #5 on Sat 13 Feb 2010 12:56 AM (UTC)

Amended on Sat 13 Feb 2010 12:59 AM (UTC) by Worstje

Message
Nope I don't translate at all. And when I tried it, selecting Afrikaans (was at the top of the list) didn't do boopkiss.

I think it is totally broken on Opera currently. Or I am jinxed.

(Not that they'd care either way, Google Translate is probably still in beta!)

Plain Google Translate works fine for me though, it's just your javascript thingymajiggy.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #6 on Sat 13 Feb 2010 12:59 AM (UTC)

Amended on Sat 13 Feb 2010 01:04 AM (UTC) by Nick Gammon

Message
Google's recommended javascript.

Namely:


<div id="google_translate_element"></div>
<script>
function googleTranslateElementInit() {
new google.translate.TranslateElement({
pageLanguage: 'en'
}, 'google_translate_element');
}
</script>
<script
src="http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit">
</script>


In fact that failed the W3C validator, so I amended it to:


<div id="google_translate_element"></div>
<script type="text/javascript">
function googleTranslateElementInit() {
new google.translate.TranslateElement({
pageLanguage: 'en'
}, 'google_translate_element');
}
</script>
<script type="text/javascript"
src="http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit">
</script>


That passed the validator, but still has the problem in Opera.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Worstje   Netherlands  (899 posts)  [Biography] bio
Date Reply #7 on Sat 13 Feb 2010 01:00 AM (UTC)

Amended on Sat 13 Feb 2010 01:02 AM (UTC) by Worstje

Message
I don't think such an option is necessary, Nick. If Opera users, and maybe other exotic animals, stumble upon these issues, they can just add "http://translate.google.com/translate_a/element.js?*" to their blocked content list. (Right-click, Block Content..., Details..., Add, etc.)

It should block all the relevant translate stuff from being loaded. And when it gets fixed, we can easily remove it again. But if we remove it, we likely don't need it in the first place, so either way, it's only a loss for people who aren't using it right now. :)
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #8 on Sat 13 Feb 2010 01:03 AM (UTC)
Message
Well that seemed to work. :)

You found your own solution, well done!

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


6,450 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]