[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Tips and tricks
. . -> [Subject]  How to install MUSHclient on Windows 7
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

How to install MUSHclient on Windows 7

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Pages: 1  2  3  4 

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #45 on Tue 04 Dec 2012 08:32 PM (UTC)
Message
YmerejO42 said:

What do you have to have to compile MUSHclient? I have Visual Studio 2008 Express, would that work?


Express won't work because MUSHclient uses MFC, and that is not part of the freebie stuff they distribute.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by YmerejO42   USA  (25 posts)  [Biography] bio
Date Reply #46 on Wed 05 Dec 2012 07:07 AM (UTC)
Message
Well, thanks for answering the question, although it's a little out-of-date now. lol
[Go to top] top

Posted by WhiteWolf   Canada  (18 posts)  [Biography] bio
Date Reply #47 on Fri 18 Jan 2013 08:16 AM (UTC)
Message
Hello, I had an unusual glitch with my desktop copy of MushClient v. 4.84, and I'd managed to narrow it down to one type of trigger, and the script (using VBScript) that it calls ( my 'pose-clipper' script)

My laptop runs Windows 7 Home Premium x64, without any issues. My desktop was also running Win 7 Home Premium x64, but it was kicking back an error upon startup:

(* well, it was until I disabled all the related triggers... something about access to "OnGagTrigger" the call for the script in my glitch'd trigger *)

It was still kicking this back the following error despite my not having anything that really could trigger it (it was triggering on a name that is not set in the trigger list, and nothing else on the line is set either...)

Trigger function "OnGagTrigger" cannot execute - scripting disabled/parse error.

I narrowed it down to that type of triggers, and the script, by disabling the triggers as a while at first, then the 'pose-clipper' ones manually - a tedious process)

I finally tried the solutiuon that worked... copy the installed MushClient directory from my laptop to my desktop (it goes into C:/Program Files (x86)/MushClient in both systems, and hey presto, the 'glitch' vanished.

So, my question becomes, was anything changed recently in the 4.84 install compared to the originally distributed one? If so, its got a glitch... I'm just glad I could salvage from my laptop...

Then again, maybe something in my desktop was preventing something from running correctly (or at least ~installing~ correctly) as the brute-force copy/paste worked. A manual look-compare saw identical files/sizes/dates... so If you changed sommat, please, swap it back?

WhiteWolf McBride
faithful MushClient user (yea, I prefer my formatting... its a Client for Mushes, right?)
[Go to top] top

Posted by Ricko   (2 posts)  [Biography] bio
Date Reply #48 on Wed 20 Feb 2013 05:21 PM (UTC)
Message
help me please!!! Windows 8, starting error -> Can't open global preferences
database at:
C:/рабочий стол/днс/mushclient/
mushclient_prefs.sqlite (Error was: "unable to open
database file")
Check you have write-access
to that file. what to do???
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #49 on Wed 20 Feb 2013 09:42 PM (UTC)
Message
Make sure you install somewhere you have write-access. For example in My Documents, or Documents.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Ricko   (2 posts)  [Biography] bio
Date Reply #50 on Thu 21 Feb 2013 06:16 AM (UTC)
Message
Explain in detail please.
[Go to top] top

Posted by Fiendish   USA  (1,641 posts)  [Biography] bio   Global Moderator
Date Reply #51 on Thu 21 Feb 2013 02:09 PM (UTC)

Amended on Thu 21 Feb 2013 02:12 PM (UTC) by Fiendish

Message
MUSHclient wants to update files in its own folder. Windows UAC doesn't allow that in certain places like %ProgramFiles% or %SystemRoot%. If you want MUSHclient to run properly, you have to either not put it in a UAC protected location or run MUSHclient as Administrator.

Now I don't know what the security settings on C:\рабочий стол\ are, but try moving the MUSHclient folder to a location controlled by your user such as your user documents folder.

Also try restarting the computer. Windows could just be locking the file temporarily.

https://github.com/fiendish/aardwolfclientpackage
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


118,083 views.

This is page 4, subject is 4 pages long:  [Previous page]  1  2  3  4 

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]