[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Opening log files on Windows 7.
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Opening log files on Windows 7.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Pages: 1 2  

Posted by NodmiTheSellout   (6 posts)  [Biography] bio
Date Thu 05 Nov 2009 04:54 AM (UTC)
Message
I have no idea how to use scripts and it won't let me open the file outside of the client. When I choose the file to log to, it appears in that window, with a file size that suggests it's logging successfully, but when I right click it and try to open it, Windows tells me it can't find the file. When I go to the logs folder, it isn't there. I even tried going into safe mode, but the files still don't appear there, even though that's where I saved them. It doesn't make much sense that they're being successfully written to, but I can't open them. Can anyone tell me exactly what to do to try and open them in the client itself? Or maybe why the hell it's not appearing in the folder in Windows explorer? Every new log file I make has this problem.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Thu 05 Nov 2009 05:08 AM (UTC)
Message
NodmiTheSellout said:

... but when I right click it and try to open it, Windows tells me it can't find the file. When I go to the logs folder, it isn't there.


I don't have Windows 7 yet, but I don't quite get this bit. You see the file in Windows Explorer? And you right-click to open it? But then Windows says it isn't there? Normally you just double-click a file to open it, so what exactly are you right-clicking? Is this something to do with permissions maybe?

Where do you choose to put the log file? Maybe it should go in My Documents, and not wherever MUSHclient got installed.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by NodmiTheSellout   (6 posts)  [Biography] bio
Date Reply #2 on Thu 05 Nov 2009 06:31 AM (UTC)
Message
No no, when I open the folder itself, it isn't there. Maybe taking screen shots would be more clear. . .

This is what it looks like when I open the folder:
http://muserae.com/images/mushlogfolder.PNG

This is what it looks like in the client:
http://muserae.com/images/mushlogclient.PNG

It does seem to be an issue of permissions (what else would the lock mean?), but the files still don't show up in safe mode, and nothing looks amiss on the permissions (I show up as the owner/creator, and I even set every thing I possibly could to "allow"). I also have this client on another computer running XP, and I made a log in the exact same way there without problems. Windows search doesn't even turn up the file; the only time I see it is when I choose a log file in MUSHclient, and the file size is bigger every time I look at it, so it's obviously being written to.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #3 on Thu 05 Nov 2009 07:37 AM (UTC)
Message
I have a suspicion Windows is being clever here, and redirecting the log file to a writeable directory (basically for legacy support).

I would try clicking on the downwards arrow next to the word "logs" in the browse dialog, and see where it is really going. Or, RH-click on one of the existing log files, and selecting Properties.

Or try this: Make sure that you have "/" as the scripting prefix in the Scripting configuration, and then type this into the command window (once a log file is open):


/print (GetInfo (51))


That should print the pathname of the log file. This might give a clue as to where it really is.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by NodmiTheSellout   (6 posts)  [Biography] bio
Date Reply #4 on Thu 05 Nov 2009 02:17 PM (UTC)
Message
It's still showing up as in that folder. Every file I make with MUSHclient does this (I learned this when trying to use scripting).
[Go to top] top

Posted by WillFa   USA  (525 posts)  [Biography] bio
Date Reply #5 on Thu 05 Nov 2009 05:15 PM (UTC)
Message
How to fix it.... Press CTRL+ALT+G to bring up global preferences, and select the logging tab. Change the default directory to something that's not under C:\Program Files.


Why it's happening: Microsoft has been recommending for years that applications don't write to program files on a regular basis. (In the unix world, the conecept is that executable binaries go in /bin, logs in /var/log, general configuration files in /etc). With Vista and I.E. 8 there's a mode that IE can run in for least privileged execution that sandboxes disk writes. With Win7, this sandboxing has made it into the operating system in general. It would be bad for MS to break your legacy apps, so they just quietly force old or intentionally miscoded apps into the sandbox. The log files are actually written to disk under C:\Users\<Profile>\AppData\Local\VirtualStore\......

This feature can be shut off in the security policy of the machine. I expect that like UAC (User account control), this is going to be a Win7/Vista feature that MS introduced to quell some of the "Windoze is insecure" crowd, but will annoy users to the degree that they shut it off and choose to leave the security holes open.
[Go to top] top

Posted by NodmiTheSellout   (6 posts)  [Biography] bio
Date Reply #6 on Thu 05 Nov 2009 11:12 PM (UTC)
Message
The fix seems good, thanks. I still can't seem to find the files to open, though (no AppData folder). Maybe it's hidden somehow? I guess I'll do without the old logs if I need to, but it's kind of frustrating.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #7 on Fri 06 Nov 2009 02:03 AM (UTC)
Message
You don't need to do without logs. Just change the log directory to a writable one, like somewhere in My Documents.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by NodmiTheSellout   (6 posts)  [Biography] bio
Date Reply #8 on Fri 06 Nov 2009 05:29 AM (UTC)
Message
Yes, I did that part and it's working out, but I still can't open and view the old ones.
[Go to top] top

Posted by WillFa   USA  (525 posts)  [Biography] bio
Date Reply #9 on Fri 06 Nov 2009 06:01 AM (UTC)
Message
The AppData folder is hidden. Open explorer, Hit alt, choose Tools, Options, View Tab, and change the radio button for "Show hidden files, folders and drives".


Or just type in the directory in the address bar.
[Go to top] top

Posted by Shadowfyr   USA  (1,783 posts)  [Biography] bio
Date Reply #10 on Fri 06 Nov 2009 05:40 PM (UTC)
Message
See.. That is the thing that is going to cause people to shut the feature off, the idiotically stupid decision to place files written into program directories, which might be documents/user editable settings, some place that is "hidden" by default, instead of say, some place in the document path.
[Go to top] top

Posted by NodmiTheSellout   (6 posts)  [Biography] bio
Date Reply #11 on Fri 06 Nov 2009 08:57 PM (UTC)
Message
WillFa said:

The AppData folder is hidden. Open explorer, Hit alt, choose Tools, Options, View Tab, and change the radio button for "Show hidden files, folders and drives".


Or just type in the directory in the address bar.

Thank you! Sorry you had to explain that to me. Everything's good now. New logs are saving into a normal folder, and I can open the old ones.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #12 on Fri 06 Nov 2009 09:16 PM (UTC)

Amended on Fri 06 Nov 2009 09:17 PM (UTC) by Nick Gammon

Message
Shadowfyr said:

... the idiotically stupid decision to place files written into program directories, which might be documents/user editable settings, some place that is "hidden" by default, instead of say, some place in the document path.


Well to be fair to the person that did that (that would be me, I think), in the early days of Windows the Program Files directory was writable (somewhat to my surprise), so it just kept everything neatly together. Everything was installed in one directory, and if you wanted to get rid of it, you just deleted that directory.

In fact, in the early days (Windows 3.1 was when MUSHclient first came out I think), there wasn't even a My Documents folder anyway.

This is the annoying thing about Windows, they keep changing things. People say to you "you crazy guy, you aren't doing things the way you were supposed to *last year* are you? they changed everything since then".

Under Linux, for instance, it is perfectly normal (eg. when installing Smaug) for the source, the executable, the data files, the configuration files, the player files, all to be under the *same* directory in the user's home area (in subdirectories of course, like MUSHclient does).

Now the installer file used to install MUSHclient (mushclient.nsi) is publicly available, and the NSIS installer is a free download, so anyone that wants to can improve the installer.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by WillFa   USA  (525 posts)  [Biography] bio
Date Reply #13 on Sat 07 Nov 2009 04:20 AM (UTC)
Message
Nick Gammon said:

This is the annoying thing about Windows, they keep changing things. People say to you "you crazy guy, you aren't doing things the way you were supposed to *last year* are you? they changed everything since then".

Under Linux, for instance, it is perfectly normal (eg. when installing Smaug) for the source, the executable, the data files, the configuration files, the player files, all to be under the *same* directory in the user's home area (in subdirectories of course, like MUSHclient does).


Nick, you crazy guy, you aren't doing things the way you were supposed to 14 years ago, when windows 95 introduced "program files" and "documents and settings". ;)

I'm not sure Windows is that annoying in this matter. It gave you 10 years of "you can do that, but you shouldn't" before going "you've had enough time to adapt. Can't do that anymore."

Documents and Settings :: ~/ user's home area
Program Files :: /bin, /sbin
Comparing a "per user" installation on Linux to an "all users" installation on Windows isn't exactly fair.
[Go to top] top

Posted by Shadowfyr   USA  (1,783 posts)  [Biography] bio
Date Reply #14 on Sat 07 Nov 2009 06:14 PM (UTC)
Message
That is just it though. Even some of their own things "bury" stuff in hidden files *under* the documents and settings. Apparently, you are not allowed to look at settings directly either, according to MS. All in all, its quite a mess they created.
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


20,950 views.

This is page 1, subject is 2 pages long: 1 2  [Next page]

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]