[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  Auto-Repeat Command and Up-Arrow to last Command not working.
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Auto-Repeat Command and Up-Arrow to last Command not working.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Riek   (6 posts)  [Biography] bio
Date Fri 08 May 2009 09:21 PM (UTC)

Amended on Fri 08 May 2009 09:35 PM (UTC) by Riek

Message
Hey yall, I was referred to MUSHclient by a friend and so far am loving it but there's a small problem I'm having with it. Auto-Repeat Command and using the up arrow to get your last command entered are not working for me. Strangely, there is a caveat to this. They both work when I have local command echo turned on.

I talked to the person who referred the client to me and he has no problems at all with having local echo off and bringing up his last commands. So I don't know if this problem is unique to me or not.

I'm also sorry if this isn't the right place to put this, if it's just reporting bugs to the author to fix at a later date. Or if I'm allowed to ask for help with a problem I can't seem to figure out. But if anyone has any ideas on something that could be wrong I would appreciate any suggestions and advice.

Edit: Sorry, I forgot to add that I started at using Version 4.37 then updated to 4.40. I have the same problem with both versions.
[Go to top] top

Posted by WillFa   USA  (525 posts)  [Biography] bio
Date Reply #1 on Fri 08 May 2009 09:27 PM (UTC)
Message
ALT+0 to bring up the Commands configuration page.
Click Keyboard Preferences
Check Arrow Keys Traverse History.



[Go to top] top

Posted by Riek   (6 posts)  [Biography] bio
Date Reply #2 on Fri 08 May 2009 09:28 PM (UTC)
Message
It is already checked.
[Go to top] top

Posted by WillFa   USA  (525 posts)  [Biography] bio
Date Reply #3 on Fri 08 May 2009 09:55 PM (UTC)
Message
Odd. I have "Echo My Input" off as well in version 4.40, and mine works. On the ALT+0 options page, can you check the Command History Keep <n> Lines frame and make sure there's a positive number in there? (defaults to 500, mine's set to 2000)

[Go to top] top

Posted by Riek   (6 posts)  [Biography] bio
Date Reply #4 on Fri 08 May 2009 09:57 PM (UTC)

Amended on Fri 08 May 2009 09:58 PM (UTC) by Riek

Message
Yep, it is a positive number, it is currently set to 1000. I've checked also and it seems that when local command echo is not on the command history does not get updated at all.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #5 on Sat 09 May 2009 01:54 AM (UTC)
Message
It is probable the client received an "echo off" message (possibly while asking for your password) and didn't turn echoing on again. As a security precaution, the password you type is not entered into the command history. Thus, if the server does not re-enable echoing, then nothing goes into the command history.

You can confirm this by looking at the Display menu, bottom item (No Command Echo) which is probably checked. Uncheck that and commands should be saved.

To avoid this problem permanently, go to the world configuration, Input -> Commands, and check "Ignore 'Echo Off' Messages". Then it will never do that.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Riek   (6 posts)  [Biography] bio
Date Reply #6 on Sat 09 May 2009 02:03 AM (UTC)
Message
Actually, the client always has echo on when I boot it up, even if I had turned it off before I closed it the session before. I just did what you'd told me to do and I'm still having the same problem.

[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #7 on Sat 09 May 2009 10:00 PM (UTC)
Message
Which echo are you talking about? Echoing your typing (in the Commands configuration), or the "No Command Echo" menu entry?

I tried turning of command echo, and typing a command, and it appeared in the command history.

Can you try something? Press Ctrl+H to see the command history? Is that empty, or are your commands in it?

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Riek   (6 posts)  [Biography] bio
Date Reply #8 on Sun 10 May 2009 01:45 AM (UTC)
Message
The Command History shows everything up until I turn off the Local Command Echo. After that, it stops recording any and all commands I put in.
[Go to top] top

Posted by Hanaisse   Canada  (114 posts)  [Biography] bio
Date Reply #9 on Sun 10 May 2009 04:57 AM (UTC)
Message
I've noticed this same behaviour (both behaviours actually).

I always have to go into Display and check No Command Echo every time I log into a MUD. Would be nice to have it save to world properties.

Plus, using up arrow to repeat last command (something I always relied on) doesn't work as there is no command history with echo off.

aka: Hana
Owner in Training of: Fury of the Gods
alm-dev.org:4000
[Go to top] top

Posted by WillFa   USA  (525 posts)  [Biography] bio
Date Reply #10 on Sun 10 May 2009 05:33 AM (UTC)

Amended on Sun 10 May 2009 05:36 AM (UTC) by WillFa

Message
If you leave "No Command Echo" on the display menu unchecked, and bring up the Commands option page (ALT+0) and uncheck "Echo my input in" (normally custom 10)...


I think that's the setup you're looking for. That how I'm configured and everything works. (history, up arrows, no brown text in the output window that may split an incoming line at a packet boundary thus not trigger correctly, etc etc)


(What's the difference between these 2 options?)
[Go to top] top

Posted by Hanaisse   Canada  (114 posts)  [Biography] bio
Date Reply #11 on Sun 10 May 2009 05:45 AM (UTC)
Message
Oh, interesting. That does work.
I assume it's allowing echo but just hiding it from view.

Thanks WillFa.

aka: Hana
Owner in Training of: Fury of the Gods
alm-dev.org:4000
[Go to top] top

Posted by Riek   (6 posts)  [Biography] bio
Date Reply #12 on Sun 10 May 2009 08:42 PM (UTC)
Message
Yes, thank you WillFa for that fix! Local echo is not displaying now and the command history works, this is great. Thank you to Nick Gammon also for the help =) (and the awesome client)
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #13 on Wed 13 May 2009 01:19 AM (UTC)
Message
Quote:

(What's the difference between these 2 options?)


The "echo my input in <colour>" says whether or not you want to see what you type. Regardless, it is kept in the command history.

The "no command echo" is triggered by an "echo off" from the server, generally when it asks for your password. This stops echoing, and storing in the command history, so someone can't just up-arrow to get your password back.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


11,910 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]