[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  SSH
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

SSH

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Pages: 1 2  

Posted by Syphon   (5 posts)  [Biography] bio
Date Tue 16 Jan 2007 06:00 AM (UTC)
Message
Hello, I'm trying to connect to one of my shell account via SSH with MushClient. I have read about stunnel and have tried to install it and get it to work but I keep getting this error: Failed to open configuration file stunnel.conf.
When my stunnel.conf was created by me is placed in c:/stunnel
Any Idea's ?

stunnel.conf

client = yes
output = logfile.txt

[presidium]
connect = presidium.org:22
accept = localhost:5555
[Go to top] top

Posted by Nick Gammon   Australia  (21,321 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Sat 20 Jan 2007 03:29 AM (UTC)
Message
Is that the directory with stunnel.exe in? I think it looks in the directory that the executable is in.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Syphon   (5 posts)  [Biography] bio
Date Reply #2 on Sat 20 Jan 2007 04:15 AM (UTC)
Message
Yes It is.
[Go to top] top

Posted by Nick Gammon   Australia  (21,321 posts)  [Biography] bio   Forum Administrator
Date Reply #3 on Sat 20 Jan 2007 05:46 AM (UTC)
Message
Have you accidentally called it stunnel.conf.txt? With some text editors they append a .txt to the name.

Make sure you can see filename extensions, to check this.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Shadowfyr   USA  (1,783 posts)  [Biography] bio
Date Reply #4 on Sun 21 Jan 2007 12:06 AM (UTC)
Message
Yes, its pretty much 100% certain that this will happen if you are using an MS product or they based their behaviour on MS standards. Basically, if you are using something like Notepad or even Word, to save the file you must use "stunnel.conf" *not* stunnel.conf. The "" forces the application to ignore its default type (if its not written by a moron) and use *your* exact name instead. If you don't use "", it presumes that you are saving the degfault type and automatically adds that to the end of the file. So, in Word it would produce 'stunnel.conf.doc', in notepad, 'stunnel.conf.txt', etc. Its a really annoying, but common issue.

Also, in some, if they give you the option to change the type listed in the box above the file name to *.*, it *may* also save it with your name, instead of the one it normally would, though that isn't always the case.
[Go to top] top

Posted by Syphon   (5 posts)  [Biography] bio
Date Reply #5 on Sun 21 Jan 2007 04:26 PM (UTC)
Message
Thanks, That solved my problem :)
[Go to top] top

Posted by Syphon   (5 posts)  [Biography] bio
Date Reply #6 on Sun 21 Jan 2007 05:34 PM (UTC)
Message
I got it to work now, But not completely. I'm trying to login my shell account in a buddies box via ssh, using MushClient.
But when I quick connect localhost 5555 It connects then quickly disconnects. When I connect to presidium.org 22 It connects and displays:
SSH-2.0-OpenSSH_4.1p1 Debian-6
And When I hit enter or try to enter my user name this happens and disconnects:
Protocol mismatch.
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #7 on Sun 21 Jan 2007 09:30 PM (UTC)
Message
It's not surprising that connecting directly to port 22 doesn't work, because MUSHclient doesn't speak any SSH protocol.

What's a little more surprising is that connecting to localhost 5555, which presumably is connecting to remote host 22, does nothing. I think that stunnel has a log window of sorts if you click on the tray icon; does it have any error messages?

Out of curiosity, has anyone done this successfully before? Something about it bothers me a little bit, because an SSH tunnel normally connects to a remote machine using SSH, and then tunnels your connection to *another* connection on the remote machine.

E.g. you --> localhost:5555 --> remoteserver:22 (SSH tunnel --> remoteserver:5901 (vnc)

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

Posted by Nick Gammon   Australia  (21,321 posts)  [Biography] bio   Forum Administrator
Date Reply #8 on Mon 22 Jan 2007 08:07 PM (UTC)
Message
If you look in the logfile (logfile.txt in your case) you should see some messages. When I tried it I got:


2007.01.23 07:56:53 LOG7[3636:3596]: SSL state (connect): before/connect initialization
2007.01.23 07:56:53 LOG7[3636:3596]: SSL state (connect): SSLv3 write client hello A
2007.01.23 07:56:53 LOG7[3636:3596]: SSL alert (write): fatal: handshake failure
2007.01.23 07:56:53 LOG3[3636:3596]: SSL_connect: 1408F10B: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number


The "wrong version" appeared to be the problem, so I did some research, and added this line to the stunnel.conf file:


sslVersion = SSLv2


That appeared to eliminate the error message, but then it connected and just did nothing for a while before disconnecting.

I suspect that the username/password negotiation is not working, nor do I know how to make it work.

If I may suggest, if you simply want to connect as a shell to a SSH-secured server, simply use PuTTY, as that definitely works:

http://www.putty.nl/download.html


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by ErockMahan   (81 posts)  [Biography] bio
Date Reply #9 on Fri 19 Oct 2012 04:37 PM (UTC)

Amended on Fri 19 Oct 2012 05:03 PM (UTC) by ErockMahan

Message
As near as I can tell, I'm doing everything right after meticulously following http://www.gammon.com.au/mushclient/stunnel.htm

There were a few changes here and there, so I'm not sure if this makes the difference. I had to go to the openssl website and download the version of the file mentioned, which did not contain all the components listed (libssl32.dll, libeay32.dll and openssl.exe), but I figured I'd try anyway.

Launching stunnel after doing all the configuration gave me the following result in the log:

2012.10.19 09:28:09 LOG5[5624:4220]: Reading configuration from file stunnel.conf
2012.10.19 09:28:09 LOG5[5624:4220]: FIPS mode is enabled
2012.10.19 09:28:09 LOG5[5624:4220]: Configuration successful

That looked about as good as I could hope, but MushClient seems unable to connect to 'localhost' on port '5555' as I designated (again following the isntructions blindly):

Unable to connect to "MyMUDStunnel", code = 10061 (Connection refused)

Error occurred during phase: Connecting to world: 127.0.0.1, port 5555

For assistance with connection problems see:
http://www.gammon.com.au/forum/?id=8369

Any guess where my disconnect may lie?

Oh, and I should note that I'm able to connect this SSH thing with PuTTY without a problem.
[Go to top] top

Posted by Nick Gammon   Australia  (21,321 posts)  [Biography] bio   Forum Administrator
Date Reply #10 on Fri 19 Oct 2012 11:13 PM (UTC)
Message
So I can attempt to reproduce this, can you post the contents of your stunnel.conf file.

On my tutorial page it was:


client = yes
output = logfile.txt

[mymuck]
connect = mymuck.mymucksdomain.com:8989
accept = localhost:5555

[mysecond]
connect = othermuck.com:4205
accept = localhost:5556


Presumably yours is different. In particular I need to know what MUD you are connecting to.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by ErockMahan   (81 posts)  [Biography] bio
Date Reply #11 on Fri 19 Oct 2012 11:36 PM (UTC)

Amended on Fri 19 Oct 2012 11:38 PM (UTC) by ErockMahan

Message
client = yes
output = logfile.txt

[Imperial]
connect = imperial.modeemi.fi:22
accept = localhost:5555



[Go to top] top

Posted by Nick Gammon   Australia  (21,321 posts)  [Biography] bio   Forum Administrator
Date Reply #12 on Sat 20 Oct 2012 02:02 AM (UTC)
Message
Can you give a link to the website?

When I try to SSH to imperial.modeemi.fi:22 it looks like a shell login. It asks for a username.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by ErockMahan   (81 posts)  [Biography] bio
Date Reply #13 on Sun 21 Oct 2012 07:24 AM (UTC)
Message
Then would it be related to the missing libssl32.dll, libeay32.dll and openssl.exe files? I wasn't able to find all of them on the openssl site.

The website for the mud is http://imperialmud.org/, but one does not need to connect via SSH in order to access the MUD:

I seem unable to connect to Telnet from a certain workoffice, but there is an SSH option for implementors (like myself) that I can access with PuTTY. I just miss my incredibly awesome Mushclient features...
[Go to top] top

Posted by Nick Gammon   Australia  (21,321 posts)  [Biography] bio   Forum Administrator
Date Reply #14 on Sun 21 Oct 2012 11:09 PM (UTC)
Message
I downloaded and ran this:

https://www.stunnel.org/downloads/stunnel-4.54-installer.exe

I didn't have any missing files.


- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


16,903 views.

This is page 1, subject is 2 pages long: 1 2  [Next page]

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]