[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  I want to see my brackets!
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

I want to see my brackets!

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Borgia   Italy  (10 posts)  [Biography] bio
Date Sun 15 Jan 2006 07:03 AM (UTC)
Message
My Mu* has exits like this:

Out <O>

I see them like this:

Out O>

How can I see them with the bracket < as it should be?

Thanks.

Ps: I use mushclient version 3.65
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio
Date Reply #1 on Sun 15 Jan 2006 07:06 AM (UTC)
Message
I'm pretty sure MUSHclient doesn't remove brackets like that. Maybe MXP is on, and is interpreting it as MXP? Try turning off MXP.

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Shadowfyr   USA  (1,783 posts)  [Biography] bio
Date Reply #2 on Sun 15 Jan 2006 05:27 PM (UTC)
Message
Yes. That is likely the issue. zMud's own standard says *very* clearly that < and > in normal text *must* be replaced with &lt and &gt, but.... zMud itself ignores this requirement. Since most people who add MXP to their muds use zMud as their test client, what should be an error, i.e. using < and > as text, not an MXP tag, is instead displayed as though nothing was wrong. Mushclient follows the spec and assumes that anything in between < and > that isn't a recognized command *must* be an error. You Mu* is obviously one of the many that incorrectly assumes that they can simply ignore the requirement, since it works fine in zMud.

I can't help but think of this like the way HTML developed. IE has the worst standards compliency in any browser, but until very recently everyone used it as a test platform for determining if a page worked anyway. Some fools still do, and as result, those pages don't work right in any other browsers, even though they often contain nothing specific to IE, they just don't follow standards. In this case, the irony is that the "original" client that supported the standard must be assumed to be screwing up, unless and until Zugg ever bothers to ammend his own specifications to say that invalid information should fall through (like your MU* apparently expects), or if Mushclient is in fact correctly handling the mistake.
[Go to top] top

Posted by Nick Gammon   Australia  (21,323 posts)  [Biography] bio   Forum Administrator
Date Reply #3 on Sun 15 Jan 2006 11:21 PM (UTC)

Amended on Sun 15 Jan 2006 11:22 PM (UTC) by Nick Gammon

Message
I assume the MUD uses MXP? Otherwise you wouldn't have the problem.

It is amazing how many MUD developers have buggy MXP code, so that they are sending <O> when they should send:


&lt;O&gt;


... when MXP is enabled.


You could conceivably write a plugin that forces < to &lt; when it is not followed by a valid MXP name, but what about this:


Exits: <I>n <B>ank <U>ndertaker


All these are valid MXP codes:


  • <I> - italics
  • <B> - bold
  • <U> - underscore


That means such lines will be rendered incorrectly and there is nothing the client can do to fix it.

I suggest you post a message to the admins of the MUD suggesting they fix up their MXP implementation.

I have a page describing how to do that here:


http://www.gammon.com.au/mushclient/addingservermxp.htm


Even if they don't want to change everything, they can at least fix the code that does exits to make them work properly.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Nick Gammon   Australia  (21,323 posts)  [Biography] bio   Forum Administrator
Date Reply #4 on Mon 16 Jan 2006 07:29 PM (UTC)
Message
Quote:

My Mu* has exits like this:

Out <O>

I see them like this:

Out O>


You know what the strange thing here is? If the MUD was really in MXP mode MUSHclient would drop that altogether as an invalid tag. So you wouldn't see O> you would see nothing.

I would be interested to know what the MUD is so I could see for myself what they are actually sending.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Shadowfyr   USA  (1,783 posts)  [Biography] bio
Date Reply #5 on Mon 16 Jan 2006 08:42 PM (UTC)
Message
This *will* happen in case like <<O>>. In such cases both < characters are lost, but the last > is preserved, since the testing for the tag resets after the second < is hit. No idea why it would be doing with only one pair though, assuming we clear up the clearification of what is correct behavior in the first place, as per my other post on the subject.
[Go to top] top

Posted by Borgia   Italy  (10 posts)  [Biography] bio
Date Reply #6 on Tue 24 Jan 2006 08:02 PM (UTC)
Message
How do I try turning off the MXP thing?

By the way, I have tested with the new version of Zmud and Simplemu. Z-Mud has MPX enabled AND I can see the brackets just fine.

Nick, I think we have a friend in common, we used to RP at the same mu*.

In any case anyone interested in checking the mu*s I RP at, please e-mail me privatelly.

Thank you.
[Go to top] top

Posted by Nick Gammon   Australia  (21,323 posts)  [Biography] bio   Forum Administrator
Date Reply #7 on Tue 24 Jan 2006 08:31 PM (UTC)
Message
Quote:

This *will* happen in case like <<O>>


My test shows that in this case you only see the trailing >.

Quote:

I have tested with the new version of Zmud and Simplemu


Can you tell me the ip/port of the MUD? I'd like to see for myself what is happening. You can send me a message through the forum if you don't want to say it here.

Quote:

How do I try turning off the MXP thing?


In MUSHclient, go to Configuration -> Appearance -> MXP/Pueblo. Alter the "Use MXP/Pueblo" setting.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


5,392 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]