[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  SMAUG
. -> [Folder]  Running the server
. . -> [Subject]  Landing in Capital Ships
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Landing in Capital Ships

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Guido Sharpsword   USA  (37 posts)  [Biography] bio
Date Mon 31 Oct 2005 03:38 PM (UTC)
Message
Running SW:FotE 1.2 with only the 2 billion vnum snippet, but the problem was before that.

Ok, When I try to land i na Capital ship it says something to the effect of Landing aborted, pulling up. It's almost like the room doesn't have the can_land and can_fly flags, but they do. The bay doors are also open. Any ideas or links to a fix or something? Anyone else have this issue?

-------
Guido Sharpsword
[Go to top] top

Posted by Zeno   USA  (2,871 posts)  [Biography] bio
Date Reply #1 on Mon 31 Oct 2005 05:54 PM (UTC)
Message
I seem to remember that capital ships can't land.

Zeno McDohl,
Owner of Bleached InuYasha Galaxy
http://www.biyg.org
[Go to top] top

Posted by Guido Sharpsword   USA  (37 posts)  [Biography] bio
Date Reply #2 on Mon 31 Oct 2005 06:59 PM (UTC)
Message
OK, I'M TRYING TO LAND IN THE CAPITAL SHIP, HAHA. THE SHIP IS ORBITING YAVIN IV.

-------
Guido Sharpsword
[Go to top] top

Posted by Nick Cash   USA  (626 posts)  [Biography] bio
Date Reply #3 on Mon 31 Oct 2005 08:31 PM (UTC)
Message
You have to set which room is the hanger on the capital ship. Check the setship command.

~Nick Cash
http://www.nick-cash.com
[Go to top] top

Posted by Guido Sharpsword   USA  (37 posts)  [Biography] bio
Date Reply #4 on Mon 31 Oct 2005 09:25 PM (UTC)
Message
I have both set as the hanger. It has hanger1 and hanger2 set to the right rooms. i even tried taking indoors off, but to no avail. argh! at least it doesn't crash it like it did the first time i tried!

-------
Guido Sharpsword
[Go to top] top

Posted by Samson   USA  (683 posts)  [Biography] bio
Date Reply #5 on Mon 31 Oct 2005 11:34 PM (UTC)
Message
Just a side note here. You mentioned using "swfote 1.2" and the only version I know of with that marker is the FUSS package. You should not have needed to apply the 2 billion vnums code as that was already done as part of a bugfix a long time ago.

SmaugMuds.org: http://www.smaugmuds.org - The Smaug MUDs Community Center

"The past was erased, the erasure was forgotten, the lie became truth." -- George Orwell, 1984
[Go to top] top

Posted by Guido Sharpsword   USA  (37 posts)  [Biography] bio
Date Reply #6 on Tue 01 Nov 2005 03:03 AM (UTC)
Message
Well, I had to, cos they left out the part where you change 37067 (or whatever random number it was) to MAX_VNUMS in almost all of the documents. The other part of the 2 billion snippet was done.


Any clue about the landing on cap ships, tho? I'm at a huge loss.

-------
Guido Sharpsword
[Go to top] top

Posted by Greven   Canada  (835 posts)  [Biography] bio
Date Reply #7 on Wed 02 Nov 2005 01:17 AM (UTC)
Message
You can't land Caps in any SWR that I'm aware of. Look at the structure of a Nebulon B frigate and think about how that would land.

There is a section in update_space I beleive that has the check for it, if you really want to land a capital ship on a planet you could take that out. Open space.c and search for the error string.

Nobody ever expects the spanish inquisition!

darkwarriors.net:4848
http://darkwarriors.net
[Go to top] top

Posted by Guido Sharpsword   USA  (37 posts)  [Biography] bio
Date Reply #8 on Wed 02 Nov 2005 03:00 AM (UTC)
Message
Once again, I'm not trying to get the CAPITAL SHIP ON THE GROUND I am trying to ge tthe STARFIGHTER in the Capital ship. You know, Open Bays and all that stuff.

-------
Guido Sharpsword
[Go to top] top

Posted by Greven   Canada  (835 posts)  [Biography] bio
Date Reply #9 on Wed 02 Nov 2005 07:21 PM (UTC)
Message
Well then what is the exact error message are you getting? There are alot of things that would prevent you from landing.

Get the error message, search for that string in space.c, and check what the conditions where to print that message. That will tell you at least whats going wrong.

Nobody ever expects the spanish inquisition!

darkwarriors.net:4848
http://darkwarriors.net
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


7,134 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]