[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  Dawn of Time
. -> [Folder]  Configuration
. . -> [Subject]  Newbie
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Newbie

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Abrasive   (2 posts)  [Biography] bio
Date Fri 06 Dec 2002 05:09 PM (UTC)
Message
I'm a complete newbie to DoT - Can anyone point me in the right direction for started/configuring the integrated web?
Any help is appreciated
[Go to top] top

Posted by Kalahn   United Kingdom  (138 posts)  [Biography] bio
Date Reply #1 on Sun 08 Dec 2002 09:33 PM (UTC)
Message
I assume you have the mud up and running already?

If not check out the getting started document at http://www.dawnoftime.org/

The integrated webserver is automatically enabled and doesn't really require any configuration.

The only exception to this is the ability to set a style sheet within the gameedit interface (within the game once it is up and running.

Ask again if that didn't help,

- Kal

Kalahn
Developer of the Dawn of Time codebase
http://www.dawnoftime.org/
[Go to top] top

Posted by Abrasive   (2 posts)  [Biography] bio
Date Reply #2 on Mon 09 Dec 2002 05:58 AM (UTC)

Amended on Mon 09 Dec 2002 06:01 AM (UTC) by Abrasive

Message
I've got the mud up and running perfectly.
I think what I'm missing is the port information on the web server, and how to link it together to make the web page.

Also, another question you may have heard a dozen times. Is there a way to set up the mud to run itself if it goes down? Or an automated reboot?
I'm running the code on a windows 2000 advanced server, and I'm running microsoft visual c++ 6

thanks
[Go to top] top

Posted by Ixliam   (5 posts)  [Biography] bio
Date Reply #3 on Wed 18 Dec 2002 04:05 PM (UTC)
Message
It doesn't really make you a webpage, you just need a link on your website to point to your mud and the correct web port. No idea on how to make it run on your windows box, unless you created some kinda batch/script and ran it as a service. In Linux, which is what you should run if you want to be able to do anything, you can get perl script called bootmud.pl and run that perlscript as a cron job, and then set it to run every 5 minutes or so. What the bootmud.pl does is ping your mud, and if it is down, it reboots it.
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


7,115 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]