[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  SMAUG
. -> [Folder]  Running the server
. . -> [Subject]  Nohup failed to run command 'startup': No such file - Swfotefuss Help
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Nohup failed to run command 'startup': No such file - Swfotefuss Help

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Rask   (1 post)  [Biography] bio
Date Wed 12 Apr 2017 11:06 PM (UTC)
Message
Hello!

Apologies in advance for what is probably a newbie question and also if this is in the wrong place.

I've worked my way through getting swfotefuss compiled in Cygwin, required files missing from System32 fixed etc etc and I feel like I'm close only to now have run into yet another roadblock.

The instruction in the First Readme says the best way to boot the MUD is using nohup startup 4000 &, which I have tried and gotten:

$ nohup: ignoring input and appending output to 'nohup.out'
nohup: failed to run command 'startup': No such file or directory

Which is odd because the startup file is in the src directory. I've examined the file and the code seems to be correct, near as I can tell anyways.

If I skip starting it through Cygwin and instead just use the swr.exe in the src directory I get a windows error:

The application was unable to start correctly (0xc000007b). Click OK to close the application.

I can't figure out why that is popping up either. I have replaced every file that might have been acting up and redownloaded/installed .NET framework and anything else that could be the cause. I've also gone through the Windows event log for extra details and found nothing helpful.


Any help or ideas would be greatly appreciated and of course if there is more info needed let me know what it is and I'd be happy to provide it.

Thanks in advance!
[Go to top] top

Posted by Nick Gammon   Australia  (21,321 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Thu 13 Apr 2017 08:49 PM (UTC)
Message
It should be:


nohup ./startup 4000 &


The path is required (ie. the current directory) or it looks for a command in your default path.

As for running it without startup, it expects to be run in the area directory so it can read the area files. So you could do this:


cd ../area        # change to area directory
../src/swr 4000   # run the .exe found in the src directory

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


1,118 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]