[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  General
. . -> [Subject]  Strange connection error - 10013 (Permission denied)
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Strange connection error - 10013 (Permission denied)

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Helmic   USA  (1 post)  [Biography] bio
Date Tue 10 Aug 2010 09:47 AM (UTC)

Amended on Tue 10 Aug 2010 09:58 AM (UTC) by Helmic

Message
---------------------------
MUSHclient
---------------------------
Unable to connect to "New Worlds Ateraan", code = 10013 (Permission denied)

Error occurred during phase: Connecting to world: 207.235.90.9, port 4002

For assistance with connection problems see: http://www.gammon.com.au/forum/?id=8369

This message can be suppressed, or displayed in the main window.
See the File menu -> Global Preferences -> General to do this.
---------------------------
OK   
---------------------------


Using Windows 7, if that's relevant.

This comes up instantly whenever I try to connect, so I know it's somewhere on my side of the connection. I can't connect to the MUD via telnet or other clients, Java browser clients included. A strange exception, however, is the flash client at www.mudconnect.com - it'll connect to the MUD no problem. I can also connect to any other MUD via MUSHclient. My IP hasn't been banned, nor have I done anything to get banned.

Since MUSHclient doesn't even wait to try to see if I'm even online or not, I turned off ZoneAlarm and double-checked to see if the Windows firewall was off as well. No luck. I did a quick check with tracert:

C:\Users\Joshua>tracert ateraan.com

Tracing route to ateraan.com [207.235.90.9]
over a maximum of 30 hops:

  1  General failure

Trace complete.


What's sorta odd is that I can visit the <a href="www.ateraan.com">website</a> itself just fine. I could play the game just fine before as well, and I don't know what could have caused this error to start coming up.

Now, I usually use a wireless connection and I regularly use several different wireless networks. Same error for all of them, and it comes up just the same whether I'm connected or disconnected to the Internet.

I've searched this forum for any possible explanations, but nothing. I was using MUSHclient 4.52 and just upgraded to 4.56, nothing changed.

It seems <a href="http://www.overflowingforum.com/viewtopic.php?f=17&t=2107">the only other person on the internet</a> that's ever had a similar problem just magically "fixed it" without knowing what he was doing. Would anyone be able to guess what's preventing me from connecting?
[Go to top] top

Posted by Nick Gammon   Australia  (21,607 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Tue 10 Aug 2010 11:20 AM (UTC)
Message
You seem to have done a lot of diagnostics, very good. :)

There are a few subtle differences between the things that work and those that don't.

For one thing, tracert uses ICMP packets (not TCP packets) - it is possible to get to a web site using TCP (eg. your web browser) but not using ICMP.

It is interesting that the Flash client works, that tends to suggest a permissions issue at your end, for example, the firewall is configured to allow your web browser to access the Internet but not other programs (and since the web browser can get to the site, it isn't totally surprising the Flash plugin also can).

If *nothing* could get through I would suspect your firewall or router configuration, however as you can connect via the Flash client it sounds more like a PC issue (the PC firewall).

You could try a couple of things:


  • Try connecting via a different PC (eg. a laptop) through the same router

  • Try booting the PC off a Ubuntu stand-alone CDROM (you can download for free) to see if the exact hardware you have can connect if using a different operating system.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Giddeon   (3 posts)  [Biography] bio
Date Reply #2 on Mon 13 Dec 2010 10:59 PM (UTC)
Message
I had this same prob, also on Windows 7.
Problem was that Windows Firewall was blocking it.
Make a rule to allow it or install another firewall (like your ZoneAlarm) and disable the Windows one.

I'd been trying to use just Windows Firewall on Windows 7, but I was annoyed so much by one program punching it's own hole in the firewall (software by Apple, btw) that I installed an additional firewall too.

I've been running the Windows one and the new one for the last month or so and I'm comfy enough with the new one now to disable the Windows one. If you do decide to disable the Windows one, note you need to disable it in all the different profiles.
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


5,101 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]