[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  Connecting to... default gateway.
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Connecting to... default gateway.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Kerish   (6 posts)  [Biography] bio
Date Sun 18 Apr 2010 10:20 AM (UTC)
Message
Yep. Its not a common thing, just something that happens once in a blue moon, but I figured I'd make a note of this so its known.

So, every once in a while, when opening a saved world just after starting the program, MUSHClient will attempt to connect to my default gateway(which thanks to my linksys router is 192.168.1.1). I have no idea what causes this or why, but I figured it might be worth noting in case its evidence of a larger issue. Its not a huge problem, since its resolved simply by closing and re-opening the client. Like I said, just making a note of it in case anyone might know -why- it does this from time to time.
[Go to top] top

Posted by Nick Gammon   Australia  (21,322 posts)  [Biography] bio   Forum Administrator
Date Reply #1 on Sun 18 Apr 2010 11:06 AM (UTC)

Amended on Sun 18 Apr 2010 11:07 AM (UTC) by Nick Gammon

Message
I haven't heard of this before.


  • Which version are you using?

  • Did you download it from this site?

  • Have you got a world file set to automatically start up when the client opens?

  • Or more than one?

  • Do any of these worlds have chat enabled?

  • Do you have any plugins installed? Maybe the plugin is connecting or changing things.

  • How do you correct it? Is the IP address in the world file actually changed? So do you have to change it back?

  • Is the IP address in the world file(s) a numeric address (eg. 192.168.1.1) or a name (eg. ardwolf.com)?



Without any world files opening it shouldn't be connecting to anything at all, let alone the wrong IP address. And if it has the wrong IP address for some reason I don't know why it would change back by simply closing the client and re-opening it.

Maybe the DNS server is not working properly when the world name is looked up, and it recovers.

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by David Haley   USA  (3,881 posts)  [Biography] bio
Date Reply #2 on Sun 18 Apr 2010 06:25 PM (UTC)
Message
This sounds like a network configuration error; MUSHclient uses Winsock, which makes the networking decisions when it comes to name lookup, gateways, etc.

Does it go away when you try again a few times without closing the client? Do all your other internet applications work when this is happening?

David Haley aka Ksilyan
Head Programmer,
Legends of the Darkstone

http://david.the-haleys.org
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


3,138 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]