[Home] [Downloads] [Search] [Help/forum]

Gammon Forum

See www.mushclient.com/spam for dealing with forum spam. Please read the MUSHclient FAQ!

[Folder]  Entire forum
-> [Folder]  MUSHclient
. -> [Folder]  Bug reports
. . -> [Subject]  Socket timeout when connecting versions >4.27
Home  |  Users  |  Search  |  FAQ
Username:
Register forum user name
Password:
Forgotten password?

Socket timeout when connecting versions >4.27

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page


Posted by Renoard   (2 posts)  [Biography] bio
Date Thu 05 Jan 2017 12:06 AM (UTC)
Message
When I install any version of mushclient later than 427 I get timeout errors hen connecting to telnet. 427 works without issue and connects quickly.

Windows 10 32bit
windows firewall whitelists mushclient
quick connect fails identically to world xmls
have verified uri, ip and ports on multiple servers
have cleared stored ip just in case

I'd love to try the newer features. 427 is nice but a little dated and the commercial alternative is so bloated with runtime interpreted scripts it maneuvers like a drunken pig, or maybe a warcow.
[Go to top] top

Posted by Fiendish   USA  (1,641 posts)  [Biography] bio   Global Moderator
Date Reply #1 on Thu 05 Jan 2017 12:40 AM (UTC)
Message
It works fine for thousands of other people. Maybe there is something particular to your configuration. What more information can you provide?

https://github.com/fiendish/aardwolfclientpackage
[Go to top] top

Posted by Nick Gammon   Australia  (21,324 posts)  [Biography] bio   Forum Administrator
Date Reply #2 on Thu 05 Jan 2017 12:41 AM (UTC)
Message
I can't see anything in the release notes for 4.28 that would appear to relate to this issue. What is the current version you are trying? The latest release if 5.04:

http://www.gammon.com.au/forum/?id=13888

- Nick Gammon

www.gammon.com.au, www.mushclient.com
[Go to top] top

Posted by Renoard   (2 posts)  [Biography] bio
Date Reply #3 on Fri 06 Jan 2017 11:04 PM (UTC)
Message
As it turns out. I was mistaken. I'd seen this error when I upgraded once before. And was forced to revert to the earlier version.

When I upgraded to 5.04 (hoping the error would have been fixed. I thought I was seeing the same fault as previously. I was mistaken. 5.04 works fine, the server I was attempting to contact: game.wotmud.org:2224 was crashed and refusing connections.

Flash has a notice up before the rejection now.

Fiendish and Nick, thanks for your quick response, sorry I was wasting your time.

}:/
[Go to top] top

The dates and times for posts above are shown in Universal Co-ordinated Time (UTC).

To show them in your local time you can join the forum, and then set the 'time correction' field in your profile to the number of hours difference between your location and UTC time.


1,585 views.

It is now over 60 days since the last post. This thread is closed.     [Refresh] Refresh page

Go to topic:           Search the forum


[Go to top] top

Quick links: MUSHclient. MUSHclient help. Forum shortcuts. Posting templates. Lua modules. Lua documentation.

Information and images on this site are licensed under the Creative Commons Attribution 3.0 Australia License unless stated otherwise.

[Home]


Written by Nick Gammon - 5K   profile for Nick Gammon on Stack Exchange, a network of free, community-driven Q&A sites   Marriage equality

Comments to: Gammon Software support
[RH click to get RSS URL] Forum RSS feed ( https://gammon.com.au/rss/forum.xml )

[Best viewed with any browser - 2K]    [Hosted at FutureQuest]